Integracja BleBox z Domoticz

  • 89 Odpowiedzi
  • 5365 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline lukwro

  • * 7
  • 0
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #75 dnia: Październik 02, 2017, 06:55:22 pm »
U mnie akurat sterowanie z poziomu Domoticza działa poprawie. Problem mam tylko przy sterowaniu zewnętrznym przyciskiem.
*

Offline fantom

  • ** 57
  • 2
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #76 dnia: Październik 02, 2017, 09:02:07 pm »
A to raczej nie wina domoticza. Ustaw te przykładowe 30% i sprawdz co pokazuje json przez strone www (podawalem jak pobrać te dane kilka postów wyżej). I zobacz jaki jest desirepos itp

Fantom
*

Offline rolfo

  • * 2
  • 0
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #77 dnia: Październik 02, 2017, 09:08:01 pm »
Ok, już wiem o co chodzi. Wygląda to tak, mam nadzieję, że będzie widać :)
Suwak w domoticzu:
1. |x--------|    - roleta zamknięta
2. |--------x|    - roleta otwarta

ale:

3. |-x-------|    - prawie cała otwarta
4. |-------x-|    - prawie cała zamknięta.

Czyli z pozycji 3 (gdzie 90% okna jest odsłonięte), przesunięcie suwaka w lewo powoduje całkowite zasłonięcie okna. Tak samo z pozycji 4 (gdzie 90% okna przesłania roleta), przesunięcie w prawo do końca powoduje całkowite otwarcie.

EDIT: w pozycji 3, kostka pokazuje to (sorry, za formatowanie, ale mam tam do dyspozycji tylko wgeta).

{
"state":2,
"currentPos":
{"position":6,
"tilt":-1},
"desiredPos":
{"position":6,"tilt":-1},
"favPos":{"position":50,"tilt":50},
"controlType":1,
"moveDirectionSwap":0,
"inputsSwap":0,
"calibrationParameters":{"isCalibrated":1,"maxTiltTimeUpMs":1100,"maxTiltTimeDownMs":1100},"moveTimeoutMs":120000}
« Ostatnia zmiana: Październik 02, 2017, 09:11:06 pm wysłana przez rolfo »
*

Offline DaM

  • * 5
  • 0
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #78 dnia: Październik 23, 2017, 08:33:41 pm »
Witam,
mam problem z obsługą modułów Switch Box D.

Po dodaniu urządzenia pojawiają się dwa wpisy:

ID Nazwa Adres IP Typ Uptime Sprzęt Firmware
2 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120
1 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120

Po czym dodają się kolejne z adresem IP 160.0.182.15:
ID Nazwa Adres IP Typ Uptime Sprzęt Firmware
4 Switch Box D 160.0.182.15 unknown unknown unknown unknown
3 Switch Box D 160.0.182.15 unknown unknown unknown unknown
2 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120
1 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120

I te dwa z nieprawidłowym adresem działają, ale tylko do restartu domoticza.

W urządzeniach tak to wygląda:
  Turn On 1 Blebox 0A000B6F 0 Switch Box D Lighting 2 AC
  Turn On 2 Blebox 0A000B6F 1 Switch Box D Lighting 2 AC
  Turn On 3 Blebox A000B6F 0 Switch Box D Lighting 2 AC
  Turn On 4 Blebox A000B6F 1 Switch Box D Lighting 2 AC

Po restarcie przestają działać, a w logu mam tylko:
017-10-23 21:27:28.112 User: Admin initiated a switch command (3/Switch Box D/On)
2017-10-23 21:27:28.113 Error: BleBox: unknown device (10.0.11.111)
2017-10-23 21:27:30.341 User: Admin initiated a switch command (4/Switch Box D/On)
2017-10-23 21:27:30.341 Error: BleBox: unknown device (10.0.11.111)
2017-10-23 21:27:31.823 User: Admin initiated a switch command (2/Switch Box D/On)
2017-10-23 21:27:31.823 Error: BleBox: unknown device (10.0.11.111)
2017-10-23 21:27:33.120 User: Admin initiated a switch command (1/Switch Box D/On)
2017-10-23 21:27:33.120 Error: BleBox: unknown device (10.0.11.111)

Używam wersji beta, zarówno pobranej binarki jak i samodzielnie kompilowanej:
Version: 3.8627
Build Hash: 93492f2-modified
Compile Date: 2017-10-22 13:31:11
dzVents Version: 2.3.0

Ktoś się spotkał z podobnym problemem lub wie gdzie szukać przyczyny?

EDIT: nadanie bleboxowi adresu z klasy 192.168.5.0/24 wyeliminowało problem pojawiających się wpisów z adresem 160.0.182.15, jednak nadal po restarcie przestaje działać.
EDIT2: po dodaniu kolejnego urządzenia, to wcześniej dodane zaczyna działać i tak sobie działają obydwa, aż do restartu...
« Ostatnia zmiana: Październik 23, 2017, 10:45:43 pm wysłana przez DaM »
*

Offline fantom

  • ** 57
  • 2
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #79 dnia: Październik 24, 2017, 07:01:28 am »
Pytanie: w jaki sposób były dodane te dwa pierwsze urządzenia ? Czy automatycznym wyszukaniem czy ręcznie adres IP był wpisany ?

Fantom
ps. Postaram, się dzisiaj lub jutro zerknąć gdzie może być problem.
*

Offline DaM

  • * 5
  • 0
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #80 dnia: Październik 24, 2017, 07:57:10 am »
Efekt jest taki sam przy automatycznym i ręcznym dodawaniu.

EDIT: sprawdziłem na wersji stabilnej i tutaj po restarcie domoticza wszystko cały czas działa jak należy.
EDIT2: poradziłem sobie z problemem restartów przez przywrócenie metody bool BleBox::StartHardware() z wersji stabilnej:
bool BleBox::StartHardware()
{
if (LoadNodes())
{
m_thread = boost::shared_ptr<boost::thread>(new boost::thread(boost::bind(&BleBox::Do_Work, this)));
m_bIsStarted = true;
sOnConnected(this);
return (m_thread != NULL);
}
return false;
}

Ps. Udało mi się naprawić obsługę (a właściwie zrobić ją na nowo) modułu wLightBox, muszę to trochę uporządkować i udostępnię repozytorium, może będzie ktoś chętny przetestować.
« Ostatnia zmiana: Październik 24, 2017, 11:33:26 am wysłana przez DaM »
*

Offline fantom

  • ** 57
  • 2
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #81 dnia: Październik 24, 2017, 05:39:11 pm »
Ładowanie BleBox na start już poprawiłem i czeka w pull-request:
https://github.com/domoticz/domoticz/pull/1890/commits/8e7be00e60e6879117b8a1057c35e8eab56f5f4f

pozdrawiam
Fantom
« Ostatnia zmiana: Październik 24, 2017, 05:49:59 pm wysłana przez fantom »
*

Offline fantom

  • ** 57
  • 2
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #82 dnia: Październik 24, 2017, 05:48:18 pm »
Witam,
mam problem z obsługą modułów Switch Box D.

Po dodaniu urządzenia pojawiają się dwa wpisy:

ID Nazwa Adres IP Typ Uptime Sprzęt Firmware
2 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120
1 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120

Po czym dodają się kolejne z adresem IP 160.0.182.15:
ID Nazwa Adres IP Typ Uptime Sprzęt Firmware
4 Switch Box D 160.0.182.15 unknown unknown unknown unknown
3 Switch Box D 160.0.182.15 unknown unknown unknown unknown
2 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120
1 Switch Box D 10.0.11.111 Switch Box D 0:00:22 0.7 0.120

I te dwa z nieprawidłowym adresem działają, ale tylko do restartu domoticza.

W urządzeniach tak to wygląda:
  Turn On 1 Blebox 0A000B6F 0 Switch Box D Lighting 2 AC
  Turn On 2 Blebox 0A000B6F 1 Switch Box D Lighting 2 AC
  Turn On 3 Blebox A000B6F 0 Switch Box D Lighting 2 AC
  Turn On 4 Blebox A000B6F 1 Switch Box D Lighting 2 AC

Dobra. Ten błąd chyba też znalazłem. Teraz adres może być też 160.x.x.x
Trzeba poczekać aż pull request trafi do bety i można testować:
https://github.com/domoticz/domoticz/pull/1890/commits/a84d545f322542bc2f52015e9f835c0ad1fbba26

pozdrawiam
Fantom
« Ostatnia zmiana: Październik 24, 2017, 05:58:12 pm wysłana przez fantom »
*

Offline fantom

  • ** 57
  • 2
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #83 dnia: Październik 25, 2017, 11:20:52 am »
No to można ściągnąć betę i testować.
Poprawki pojawiły się w wersji >= 3.8635

pozdrawiam
Fantom
*

Offline DaM

  • * 5
  • 0
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #84 dnia: Październik 25, 2017, 09:11:09 pm »
Niestety adresy IP z klasy 10.x.x.x nadal nie działają poprawnie.
Tak na prawdę problem jest ze wszystkimi adresami gdzie pierwszy oktet adresu jest mniejszy niż 16.

Wygląda to tak jakby Domoticz traktował DeviceID jako INT i wszędzie tam gdzie pierwsza liczba adresu w HEX zaczyna się od 0 to to zero jest obcinane.
I tak np. moduł generuje dla adresu 10.0.11.111 DeviceID 0A000B6F, a Domoticz sobie bierze A000B6F i zamiast 0A = 10 mamy A0 = 160 itd., itp.

Póki co nie mam pomysłu jak to poprawić tak, żeby DeviceID było kompatybilne wstecz. Może znajdę wolną chwilę, żeby nad tym pomyśleć, a na razie przeadresuję BleBoxy do klasy 192.168.x.x
*

Offline fantom

  • ** 57
  • 2
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #85 dnia: Październik 26, 2017, 08:03:00 am »
Niestety adresy IP z klasy 10.x.x.x nadal nie działają poprawnie.
Tak na prawdę problem jest ze wszystkimi adresami gdzie pierwszy oktet adresu jest mniejszy niż 16.

Wygląda to tak jakby Domoticz traktował DeviceID jako INT i wszędzie tam gdzie pierwsza liczba adresu w HEX zaczyna się od 0 to to zero jest obcinane.
I tak np. moduł generuje dla adresu 10.0.11.111 DeviceID 0A000B6F, a Domoticz sobie bierze A000B6F i zamiast 0A = 10 mamy A0 = 160 itd., itp.

Póki co nie mam pomysłu jak to poprawić tak, żeby DeviceID było kompatybilne wstecz. Może znajdę wolną chwilę, żeby nad tym pomyśleć, a na razie przeadresuję BleBoxy do klasy 192.168.x.x

Tak.
Znalazłem błąd w logice w domoticzu w CDomoticzHardwareBase::SendSwitch
Jest tam niestety sprintf(ID, "%X%02X%02X%02X", ID1, ID2, ID3, ID4);
Czyli jest gubione pierwsze zero.
Postaram się to dać jako pull-request, ale na 99% odrzucą. Tak niestety tam już jest. Nieważne, że jest źle, ale nie poprawiamy bo innym może to coś "zepsuć" :(

Fantom
ps. Dobra. Też zrobię źle, i wtedy będzie "dobrze" :) https://github.com/domoticz/domoticz/pull/1894
ps 2 - można już pobrać nową wersję. Poprawka dostępna >= 3.8643
« Ostatnia zmiana: Październik 26, 2017, 12:12:34 pm wysłana przez fantom »
*

Offline MC

  • ** 67
  • 0
    • Zobacz profil
  • Nazwa i wersja ID: Satel Integra wrl + domoticz + ...
Odp: Integracja BleBox z Domoticz
« Odpowiedź #86 dnia: Październik 26, 2017, 09:15:42 pm »
Dziękuję bardzo za obsługę RGB ;)
*

Offline Patriko

  • Moderator
  • ***** 297
  • 16
    • Zobacz profil
  • Nazwa i wersja ID: Darin/BleBox.eu
Odp: Integracja BleBox z Domoticz
« Odpowiedź #87 dnia: Październik 29, 2017, 03:41:14 pm »
U mnie natomiast strasznie dużo "unknown" z IP 0.0.0.192, znalazlo natomiast 2 bleboxy a w tym budynku jest ich 170. Coś robię nie tak?
*

Offline DaM

  • * 5
  • 0
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #88 dnia: Październik 29, 2017, 05:56:56 pm »
Sprawdziłem u siebie i faktycznie jest problem z dodawaniem nowych urządzeń.
Urządzenie o adresie IP 192.168.6.111 dodaje się z adresem 0.0.0.192 i dostaje ID 000000C0.

Wygląda na to, że coś jest nie tak z tą poprawką https://github.com/domoticz/domoticz/pull/1894
*

Offline fantom

  • ** 57
  • 2
    • Zobacz profil
Odp: Integracja BleBox z Domoticz
« Odpowiedź #89 dnia: Październik 29, 2017, 06:35:58 pm »
No tak. Chciałem poprawić numerację a zrobiłem bez namysłu.
Po tej poprawce powinno być ok: https://github.com/domoticz/domoticz/pull/1899

Fantom
ps. Od kilku wersji nie mogę skompilować domoticza więc trochę w ciemno poprawiam :(
ps2. Od wersji 3.8661 poprawka wgrana. Można testować.
« Ostatnia zmiana: Październik 30, 2017, 06:04:02 pm wysłana przez fantom »