esp8266 2xds18b20

  • 6 Odpowiedzi
  • 1403 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline kniazio

  • ** 25
  • 0
    • Zobacz profil
  • Nazwa i wersja ID: kniazio
esp8266 2xds18b20
« dnia: Wrzesień 22, 2015, 06:17:25 am »
Jak w temacie.
Czy jest mozliwosc podpiecia dwoch dallasow?
No i oczywiscie czy jest do tego jakis kod?
Odp: esp8266 2xds18b20
« Odpowiedź #1 dnia: Wrzesień 22, 2015, 09:16:56 pm »
Też noszę się z takim zamiarem. Na zagranicznych forach znalazłem informacje, że do 7 DSów ludzie podpinają na jednym GPIO ale nigdzie kodu źródłowego w LUA.
Odp: esp8266 2xds18b20
« Odpowiedź #2 dnia: Wrzesień 23, 2015, 07:23:59 pm »
Czy ktoś z Was ma jakiś działający kod, który odczyta temperaturę z dwóch czujników?
Pół dnia z tym walczę ale bez powodzenia. Znalazłem kilka przykładów (np. TEN ale po wgraniu zawiesza się ESP i pomaga tylko flash...
« Ostatnia zmiana: Wrzesień 23, 2015, 07:28:35 pm wysłana przez sliver001 »
*

Offline kniazio

  • ** 25
  • 0
    • Zobacz profil
  • Nazwa i wersja ID: kniazio
Odp: esp8266 2xds18b20
« Odpowiedź #3 dnia: Listopad 03, 2015, 06:01:22 am »
Czy ktos z was ma taki problem?
Dwa esp, na kazdym czujnik ds18b20
Wysylam dane do thingspeak czujnik1 do field1, czujnik 2 do field2 (ten sam jeden kanal)
Mam cos takiego ze znika mi czasem jeden z czujnikow (raz jeden raz drugi) tzn nie wysyla danych do TS (ping w lokalnej odpowiada). Jak wylacze na chwile esp i wlacze ponownie to sie pojawia lub tez czasami wywala mi drugi czujnik.
Czy musze dla drugiego czujnika zalozyc drugi kanal na TS czy moze trzeba cos ustawic
Pozdrawiam
*

Offline gojac

  • * 1
  • 0
    • Zobacz profil
  • Nazwa i wersja ID: gojac
Odp: esp8266 2xds18b20
« Odpowiedź #4 dnia: Listopad 25, 2016, 02:36:41 pm »
Tu jest kawłek kodu obsługującego dwa czujniki:
http://www.electrodragon.com/w/ESP8266_NodeMCU_Lua
*

Offline zen

  • *** 132
  • 3
    • Zobacz profil
  • Nazwa i wersja ID: Domoticz / OpenHAB
Odp: esp8266 2xds18b20
« Odpowiedź #5 dnia: Listopad 25, 2016, 03:42:59 pm »
Czy ktos z was ma taki problem?
Dwa esp, na kazdym czujnik ds18b20
Wysylam dane do thingspeak czujnik1 do field1, czujnik 2 do field2 (ten sam jeden kanal)
Mam cos takiego ze znika mi czasem jeden z czujnikow (raz jeden raz drugi) tzn nie wysyla danych do TS (ping w lokalnej odpowiada). Jak wylacze na chwile esp i wlacze ponownie to sie pojawia lub tez czasami wywala mi drugi czujnik.
Czy musze dla drugiego czujnika zalozyc drugi kanal na TS czy moze trzeba cos ustawic
Pozdrawiam

Znika ci czujnik czy znika ESP? Jak to masz podłączone? Jaki pull up? Jak zasilasz ESP?
*

Offline zen

  • *** 132
  • 3
    • Zobacz profil
  • Nazwa i wersja ID: Domoticz / OpenHAB
Odp: esp8266 2xds18b20
« Odpowiedź #6 dnia: Listopad 25, 2016, 03:43:31 pm »
Ale trupa odgrzałem :)