ESP8266 - problem

  • 9 Odpowiedzi
  • 3257 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline viperlodz

  • Moderator Globalny
  • ***** 527
  • 14
    • Zobacz profil
  • Nazwa i wersja ID: HC2 3.600 | HC2 4.080 | HC2 4.110
ESP8266 - problem
« dnia: Kwiecień 19, 2015, 01:32:12 pm »
Witam,
Chciałem się doradzić odnośnie esp. Zacząłem zabawę, ale obawiam się, że mogłem zniszczyć kilka esp;)
Jeśli podłączyłem pod RST i GPI02 podłączyłem 3,3V to mogłem spalić moduł?
Chciałem zrobić wg instrukcji: https://hackaday.io/project/3465-playing-with-esp8266/log/12683-downloading-and-installing-nodemcu-firmware

Problem polega na tym, że nie mogę wgrać NodeMCU Firmware. Miga dioda na kontrolerze oraz na ESP niebieska w trakcie wgrywania ale nawet po 30 minutach nic się nie dzieje.
*

Offline Jacek

  • *** 106
  • 3
    • Zobacz profil
  • Nazwa i wersja ID: HC2 4.130, HC2 3.600, HCL 4.100
Odp: ESP8266 - problem
« Odpowiedź #1 dnia: Kwiecień 19, 2015, 01:39:16 pm »
Witam,
Chciałem się doradzić odnośnie esp. Zacząłem zabawę, ale obawiam się, że mogłem zniszczyć kilka esp;)
Jeśli podłączyłem pod RST i GPI02 podłączyłem 3,3V to mogłem spalić moduł?
Chciałem zrobić wg instrukcji: https://hackaday.io/project/3465-playing-with-esp8266/log/12683-downloading-and-installing-nodemcu-firmware

Problem polega na tym, że nie mogę wgrać NodeMCU Firmware. Miga dioda na kontrolerze oraz na ESP niebieska w trakcie wgrywania ale nawet po 30 minutach nic się nie dzieje.
Raczej nie spaliłeś tym sposobem modułów. Podczas wgrywania nowego firmwaru RST i GPIO2 może "wisieć w powietrzu" a GPIO0 ma mieć podpięte GND. CH_PD ma być podpięte do VCC.
Komendy AT chodziły poprawnie po podpięciu do UART`a ?
« Ostatnia zmiana: Kwiecień 19, 2015, 01:44:20 pm wysłana przez Jacek »
Jacek
*

Offline viperlodz

  • Moderator Globalny
  • ***** 527
  • 14
    • Zobacz profil
  • Nazwa i wersja ID: HC2 3.600 | HC2 4.080 | HC2 4.110
Odp: ESP8266 - problem
« Odpowiedź #2 dnia: Kwiecień 19, 2015, 01:46:33 pm »
Właśnie nie chodzą komendy itd. Już nawet kupiłem 3 ESP w Polsce i inny programator. Nie wiem czy problemem nie jest Windows 8. Wczoraj sztywniak mi podesłał sterowniki, ale nie da rady ich zainstalować na Windows 8, bo od razu wywala system cały.
Już nawet odwrotnie podłączałem TX i RX, bo gdzieś o tym czytałem. Podobno po uruchomieniu nodemcu-flasher powinienem zobaczyć mac, ale jest tylko info waiting MAC. Próbowałem też przez inne programy i też zero odzewu. COM ustawiony poprawnie.
*

Offline Jacek

  • *** 106
  • 3
    • Zobacz profil
  • Nazwa i wersja ID: HC2 4.130, HC2 3.600, HCL 4.100
Odp: ESP8266 - problem
« Odpowiedź #3 dnia: Kwiecień 19, 2015, 01:53:32 pm »
Właśnie nie chodzą komendy itd. Już nawet kupiłem 3 ESP w Polsce i inny programator. Nie wiem czy problemem nie jest Windows 8. Wczoraj sztywniak mi podesłał sterowniki, ale nie da rady ich zainstalować na Windows 8, bo od razu wywala system cały.
Już nawet odwrotnie podłączałem TX i RX, bo gdzieś o tym czytałem. Podobno po uruchomieniu nodemcu-flasher powinienem zobaczyć mac, ale jest tylko info waiting MAC. Próbowałem też przez inne programy i też zero odzewu. COM ustawiony poprawnie.
Czytałem  w necie, że windows 8 nie chce chodzić z oprogramowaniem ESP. Są podobno sterowniki ale niedopracowane. Spróbuj na innym systemie. Jaki masz moduł do zamiany USB <-> RS232 ?
PS
Nie zamieniaj TX i RX to może uwalić moduły !.
Jeżeli nie uzyskasz odpowiedzi ( OK ) na komendę AT nie masz co próbować dalej.
« Ostatnia zmiana: Kwiecień 19, 2015, 01:56:46 pm wysłana przez Jacek »
Jacek
*

Offline viperlodz

  • Moderator Globalny
  • ***** 527
  • 14
    • Zobacz profil
  • Nazwa i wersja ID: HC2 3.600 | HC2 4.080 | HC2 4.110
Odp: ESP8266 - problem
« Odpowiedź #4 dnia: Kwiecień 19, 2015, 01:58:36 pm »
Ten moduł: http://botland.com.pl/konwertery-usb-uart-rs232/1611-konwerter-usb-uart-ft232-33-5v.html
Właśnie mam problem z innym, bo wszędzie już mam 8;) co niestety jest problematyczne po raz kolejny. A za pomocą wirtualizacji da rade?
*

Offline Jacek

  • *** 106
  • 3
    • Zobacz profil
  • Nazwa i wersja ID: HC2 4.130, HC2 3.600, HCL 4.100
Odp: ESP8266 - problem
« Odpowiedź #5 dnia: Kwiecień 19, 2015, 02:06:42 pm »
Ten moduł: http://botland.com.pl/konwertery-usb-uart-rs232/1611-konwerter-usb-uart-ft232-33-5v.html
Właśnie mam problem z innym, bo wszędzie już mam 8;) co niestety jest problematyczne po raz kolejny. A za pomocą wirtualizacji da rade?

Dane modułu FIDI:
Wyprowadzenia
Moduł posiada wyprowadzenia w postaci kątowych złącz goldpin z sygnałami RxD, TxD, RTS, CTS oraz linie zasilania: PWR i GND. Poziom napięcia na pinie PWR wybierany jest przy pomocy zworki:
5V - zasilanie pobierane z portu USB przez bezpiecznik polimerowy zapobiegający uszkodzeniu portu (prąd maks. 500mA)
3,3V - zasilanie pobierane z wewnętrznego stabilizatora układu FTDI ( prąd maks. 50mA)

układ ESP-01 potrzebuje nawet ( w porywach ) do 300 mA ! ?
« Ostatnia zmiana: Kwiecień 19, 2015, 02:11:14 pm wysłana przez Jacek »
Jacek
*

Offline viperlodz

  • Moderator Globalny
  • ***** 527
  • 14
    • Zobacz profil
  • Nazwa i wersja ID: HC2 3.600 | HC2 4.080 | HC2 4.110
Odp: ESP8266 - problem
« Odpowiedź #6 dnia: Kwiecień 19, 2015, 02:07:49 pm »
Czyli mam podłączyć zewnętrzne zasilanie dodatkowo?
*

Offline Jacek

  • *** 106
  • 3
    • Zobacz profil
  • Nazwa i wersja ID: HC2 4.130, HC2 3.600, HCL 4.100
Odp: ESP8266 - problem
« Odpowiedź #7 dnia: Kwiecień 19, 2015, 02:20:19 pm »
Czyli mam podłączyć zewnętrzne zasilanie dodatkowo?

....warto spróbować. Ja myślę, że problem jest w 8-ce ale właściwe zasilanie  ( stabilizacja napięcia i moc zasilacza ) ma bardzo duże znaczenie  w działaniu tego elementu.
Jacek
*

Offline viperlodz

  • Moderator Globalny
  • ***** 527
  • 14
    • Zobacz profil
  • Nazwa i wersja ID: HC2 3.600 | HC2 4.080 | HC2 4.110
Odp: ESP8266 - problem
« Odpowiedź #8 dnia: Kwiecień 19, 2015, 02:21:36 pm »
Niestety to samo. Co prawda korzystałem z MB102, ale powinien ogarnąć do wgrywania. W takim razie będę kombinował z innym Windowsem.
*

Offline viperlodz

  • Moderator Globalny
  • ***** 527
  • 14
    • Zobacz profil
  • Nazwa i wersja ID: HC2 3.600 | HC2 4.080 | HC2 4.110
Odp: ESP8266 - problem
« Odpowiedź #9 dnia: Maj 09, 2015, 10:12:13 am »
Zamówiłem 4 sztukę ESP i nie wiem co się stało, ale ruszyło. Okazało się, że wcześniejsze też zaczeły działać (nie spaliłem) a nic nie zmieniałem;) Także problem rozwiązany i zamykam wątek.