ESP8266 - ThingSpeak - Google Gauge - problem

  • 3 Odpowiedzi
  • 1553 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline wjacek

  • ** 33
  • 1
    • Zobacz profil
ESP8266 - ThingSpeak - Google Gauge - problem
« dnia: Marzec 24, 2015, 11:59:46 pm »
Mam pytanie odnośnie thingspeak.com i pluginu Google Gauge.
Może ktoś wie jak za pomocą pluginu Google Gauge wyświetlać wyniki z field 1, 2, 3, ... ?
pozdrawiam,
Jacek
*

Offline andre

  • Moderator Globalny
  • ***** 212
  • 2
    • Zobacz profil
  • Nazwa i wersja ID: HC2 4.153,GRENTON, 4 x LK v2.0+OpenWRT+BLE+RPi...
Odp: ESP8266 - ThingSpeak - Google Gauge - problem
« Odpowiedź #1 dnia: Marzec 25, 2015, 12:16:40 am »
A czytałeś tutorial?   http://community.thingspeak.com/tutorials/google/display-a-google-gauge-visualization-using-thingspeak-plugins/
Jest tam skrypt do którego trzeba wstawić swoje dane,klucz do odczytu i ew. przeskalować zakres.Kiedyś to robiłem ale szczerze to nie są najpiękniejsze zegary.
*

Offline wjacek

  • ** 33
  • 1
    • Zobacz profil
Odp: ESP8266 - ThingSpeak - Google Gauge - problem
« Odpowiedź #2 dnia: Marzec 25, 2015, 12:29:25 am »
andre czytałem od dachy do dechy, jestem z tych co zanim zapytają to 3-razy przeczytają ;o).
Jeżeli jesteś oblatany w temacie to spójrz na: https://thingspeak.com/channels/30281
Chodzi o to że w jednym kanale czytam dane z DHT22 (wilgotność i temperatura) a następnie wyświetlam w Google Gauge wilgotność (field1) , która jest OK ale nie potrafię wyświetlić w Google gauge temp. (field2)
pozdrawiam,
Jacek
*

Offline andre

  • Moderator Globalny
  • ***** 212
  • 2
    • Zobacz profil
  • Nazwa i wersja ID: HC2 4.153,GRENTON, 4 x LK v2.0+OpenWRT+BLE+RPi...
Odp: ESP8266 - ThingSpeak - Google Gauge - problem
« Odpowiedź #3 dnia: Marzec 25, 2015, 01:09:30 am »
Myślę,że problem jest w ustawieniu funkcji Math.round , pamiętam,że też musiałem się natrudzić aby zobaczyć prawidłowe dane w gauge. Przeczytaj jeszcze raz sugestie Hansa i Daniela w podanym linku.